Jump to content
  • 0
TanoX

[FusionCMS] Email System Issue

Question

Hello guys,

Having a static ipv4 and a spare pc at home, I decided to host a little server for me and my friends, using Win7, Bitnami Wamp Stack, TrinityCore and FusionCMS 6.1.7.
Everything works as it should, except the email system (Password Recovery and Account Validation).

I tried every possible configuration, using Yahoo/Gmail SMTP, using the internal system, opening ports etc. and it still doesn't work... :'(
I get the message that an email was successfully sent, but nothing is received in the actual inbox.

- SMTP Settings:

$config['use_own_smtp_settings'] = 1;
$config['smtp_host'] = "ssl://smtp.gmail.com";
$config['smtp_user'] = "USERNAME@gmail.com";
$config['smtp_pass'] = "GMAIL-PASSWORD";
$config['smtp_port'] = 465;
$config['mail_debug'] = false;

- Success message:

to: 250 2.1.5 OK b72sm305649wmd.0 - gsmtp

data: 354  Go ahead b72sm305649wmd.0 - gsmtp

250 2.0.0 OK 1503901034 b72sm305649wmd.0 - gsmtp

quit: 221 2.0.0 closing connection b72sm305649wmd.0 - gsmtp

Your message has been successfully sent using the following protocol: smtp

User-Agent: CodeIgniter
Date: Sun, 27 Aug 2017 23:17:14 -0700
From: "WoW" <no-reply@yoursite.com>
Return-Path: <no-reply@yoursite.com>
To: user@yahoo.com
Subject: =?utf-8?Q?WoW:_reset_your_password?=
Reply-To: "no-reply@yoursite.com" <no-reply@yoursite.com>
X-Sender: no-reply@yoursite.com
X-Mailer: CodeIgniter
X-Priority: 3 (Normal)
Message-ID: <59a3b56a393e4@yoursite.com>
Mime-Version: 1.0


Content-Type: multipart/alternative; boundary="B_ALT_59a3b56a393ea"

This is a multi-part message in MIME format.
Your email application may not support this format.

--B_ALT_59a3b56a393ea
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit

You have requested to reset your password, to complete the request please
navigate to
http://localhost/password_recovery/requestPassword/1138e72120fcd2f4b08f12a5b82d55e6ed89b94d


--B_ALT_59a3b56a393ea
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable

You have requested to reset your password, to complete the request please n=
avigate to <a href=3D"http://localhost/password_recovery/requestPassword/11=
38e72120fcd2f4b08f12a5b82d55e6ed89b94d">http://localhost/password_recovery/=
requestPassword/1138e72120fcd2f4b08f12a5b82d55e6ed89b94d</a>

--B_ALT_59a3b56a393ea--

 

Checked and all my ports are open, Firewall off.
Also tried using the fake sendmail for windows and it works like a charm when testing with:

<?php
mail("user@yahoo.com","Subject","Email message","From: WoW@gmail.com");
?>

 

What could be the issue?
Any help is greatly appreciated, as this thing is driving me crazy.

Thanks!

Edited by TanoX

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

To make the email system work, you have to do the following settings:

1. Enable own SMTP from FusionCMS Admin, and set the following values:

$config['use_own_smtp_settings'] = 1;
$config['smtp_host'] = "ssl://smtp.gmail.com";
$config['smtp_user'] = "USERNAME@gmail.com";
$config['smtp_pass'] = "GMAIL-PASSWORD";
$config['smtp_port'] = 465;
$config['mail_debug'] = false;

2. Get a Gmail account and enable less secure apps from settings (https://myaccount.google.com/lesssecureapps)

3. Go to Gmail settings - POP/IMAP and enable IMAP.

4. Open ports in router/firewall (Port 465).

5. Go have a drink in my honor!

I spent 3 days to figure out such a simple solution, as there's absolutely no information online, on how to configure this system under FusionCMS...

Now you have it.

Enjoy! (y)

Edited by TanoX

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, TanoX said:

Issue resolved.

I had to update some Gmail settings.

Perfect, Can you share the exact settings? of course only point us to the field and what youd did to fix it. if sensitive information please censore that

Share this post


Link to post
Share on other sites
  • 0
59 minutes ago, TanoX said:

To make the email system work, you have to do the following settings:

1. Enable own SMTP from FusionCMS Admin, and set the following values:


$config['use_own_smtp_settings'] = 1;
$config['smtp_host'] = "ssl://smtp.gmail.com";
$config['smtp_user'] = "USERNAME@gmail.com";
$config['smtp_pass'] = "GMAIL-PASSWORD";
$config['smtp_port'] = 465;
$config['mail_debug'] = false;

2. Get a Gmail account and enable less secure apps from settings (https://myaccount.google.com/lesssecureapps)

3. Go to Gmail settings - POP/IMAP and enable IMAP.

4. Open ports in router/firewall (Port 465).

5. Go have a drink in my honor!

I spent 3 days to figure out such a simple solution, as there's absolutely no information online, on how to configure this system under FusionCMS...

Now you have it.

Enjoy! (y)

Thank you very much ! :)

Share this post


Link to post
Share on other sites
  • 0

The question(s) in this support topic have been answered and the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×